Unable to install TestArchitect Agent onto Genymotion
Problem
As you are installing TestArchitect Agent onto Genymotion Desktop, the “loading permanently” error may occur. The installation process cannot be completed successfully.
Cause
The error arises from the fact that the version of adb in Genymotion might be higher than that of adb in TestArchitect.
To check the version of adb in TestArchitect, do as follows:
Launch Command Prompt.
Go to the <TA_INSTALL_DIR>\device\android\tools folder
Run the command below (Learn more):
adb version
Do similarly to check the version of adb in Genymotion Desktop:
In Command Prompt, go to the <Genymotion_installion_directory>\tools folder
Run the command below:
adb version
Solution
Copy the adb.exe file in TestArchitect (located in <TA_INSTALL_DIR>\device\android\tools) as an override into the existing adb.exe file in Genymotion (located in <Genymotion_installion_directory>\tools )
LogiGear Corporation
Tel: +1 (650) 572-1400
Email: [email protected]